标签 java 下的文章

1. 为什么要升级

  1. 支持最新的Java9(虽然目前的项目还没有用到Java9,但未来升级到Java9的可能性会很高)。
  2. 基于Spring5构建,Spring5的各种新特性均可以在这里使用。
  3. 为各种组件的响应式变成提供自动化配置(虽然我们没有用到,但使用这些组件的人用起来会更顺畅)。
  4. 支持SpringMVC的非阻塞式替代方案WebFlux以及嵌入式NettyServer。
  5. 最重要的还是目前的项目依赖还比较简单。如果现在不升级,随着依赖数的增加、版本跨度增加,再升级依赖就会更加困难。

- 阅读剩余部分 -